PDA

View Full Version : Vista/7: network location resetting to public, the solution



omeg
July 14 2011, 06:39:03 PM
So, for a good while I had a very annoying glitch/problem with my home PC: when it lost internet access, even just for a second, the network connection in windows became unrecognized and reset to "Public". I use remote desktop and other stuff a lot, and in "Public" mode almost all server functions are filtered.

Extensive googling provided no solution that worked, so finally I said "fuck that" and wrote a simple service that monitors specified network connection(s) and sets them to "Private" again if anything changes. I have no idea what the root cause of that is, but I'm too lazy to find out. My solution works, so v0v.

If anyone has this problem, you can find the app (with src) here: http://omeg.pl/code/NetLocationMonitor.zip

balistic void
July 15 2011, 11:41:31 AM
Why is it losing internet access? Your router/switch might be broken. Try upgrading firmware?

Also, you have the "treat networks I connect to as public in future" checkbox selected. That's why it's defaulting.

omeg
July 15 2011, 11:49:45 AM
Why is it losing internet access? Your router/switch might be broken. Try upgrading firmware?

Also, you have the "treat networks I connect to as public in future" checkbox selected. That's why it's defaulting.
Nope, checkbox is cleared. And losing connection is due to ISP (once every few days or so).

balistic void
July 15 2011, 01:04:41 PM
Losing connection to ISP will drop internet access, but not lan access. Shouldn't reset your connection.... very strange.